// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)\[title(\s.*?)?](.*?)\[/title]").unwrap();
let string = "[title type=\"1\"]Test[/title] [title]Test2[/title]
[title type=\"6\"]Test With
Newline 3[/title]";
let substitution = "[new_title$1 title=\"$2\"]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}