# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)/$1<em>$2<\/em>$5/g;t' <<< "This text has *two* *italic* bits"