using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)";
string substitution = @"$1<em>$2</em>$5";
string input = @"This text has *two* *italic* bits";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}