import re
regex = re.compile(r"([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)")
test_str = "This text has *two* *italic* bits"
subst = "$1<em>$2</em>$5"
result = regex.sub(subst, test_str)
if result:
print(result)