$re = '/([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)/';
$str = 'This text has *two* *italic* bits';
$subst = "$1<em>$2</em>$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;