package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)`)
var str = `This text has *two* *italic* bits`
var substitution = "$1<em>$2</em>$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}