re = /([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)/
str = 'This text has *two* *italic* bits'
subst = '$1<em>$2</em>$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result