use strict;
my $str = 'This text has *two* *italic* bits';
my $regex = qr/([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)/p;
my $subst = '$1<em>$2</em>$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";