import Foundation
let pattern = #"([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This text has *two* *italic* bits"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<em>$2</em>$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)