const regex = /([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^*]|^)\\*(([^*]|(\\*\\*[^*]+\\*\\*))+)\\*([^*]|$)', 'g')
const str = `This text has *two* *italic* bits`;
const subst = `$1<em>$2</em>$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);