#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)"
Local $sString = "This text has *two* *italic* bits"
Local $sSubst = "$1<em>$2</em>$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)