// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^*]|^)\*(([^*]|(\*\*[^*]+\*\*))+)\*([^*]|$)").unwrap();
let string = "This text has *two* *italic* bits";
let substitution = "$1<em>$2</em>$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}