# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d.[0-9:,]+\s-->\s[\d+:,]+.//gs;t' <<< "5
00:05:50,141 --> 00:05:54,771
This is what was said"