use strict;
my $str = '5
00:05:50,141 --> 00:05:54,771
This is what was said';
my $regex = qr/\d.[0-9:,]+\s-->\s[\d+:,]+./sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";