import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d.[0-9:,]+\\s-->\\s[\\d+:,]+.";
final String string = "5\n"
+ "00:05:50,141 --> 00:05:54,771\n"
+ "This is what was said";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}