$re = '/\d.[0-9:,]+\s-->\s[\d+:,]+./s';
$str = '5
00:05:50,141 --> 00:05:54,771
This is what was said';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;