using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d.[0-9:,]+\s-->\s[\d+:,]+.";
string substitution = @"";
string input = @"5
00:05:50,141 --> 00:05:54,771
This is what was said";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}