const regex = /\d.[0-9:,]+\s-->\s[\d+:,]+./gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d.[0-9:,]+\\s-->\\s[\\d+:,]+.', 'gs')
const str = `5
00:05:50,141 --> 00:05:54,771
This is what was said`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);