re = /\d.[0-9:,]+\s-->\s[\d+:,]+./
str = '5
00:05:50,141 --> 00:05:54,771
This is what was said'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result