package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\d.[0-9:,]+\s-->\s[\d+:,]+.`)
var str = `5
00:05:50,141 --> 00:05:54,771
This is what was said`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}