import Foundation
let pattern = #"\d.[0-9:,]+\s-->\s[\d+:,]+."#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
5
00:05:50,141 --> 00:05:54,771
This is what was said
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)