# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(select)(.*?)(from)[\\r\\n]*/\1 count(*) \2/gim;t' <<< "SELECT\r\n money\r\nFROM\r\n accounts
\"SELECT\r\n device_id\r\nFROM\r\n temp.test_sets AS device_infos\r\nJOIN (\r\n SELECT\r\n google_ad_id\r\n FROM\r\n test*\r\n)"