import Foundation
let pattern = #"(select)(.*?)(from)[\\r\\n]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
SELECT\r\n money\r\nFROM\r\n accounts
"SELECT\r\n device_id\r\nFROM\r\n temp.test_sets AS device_infos\r\nJOIN (\r\n SELECT\r\n google_ad_id\r\n FROM\r\n test*\r\n)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 count(*) \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)