using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(select)(.*?)(from)[\\r\\n]*";
string substitution = @"\1 count(*) \2";
string input = @"SELECT\r\n money\r\nFROM\r\n accounts
""SELECT\r\n device_id\r\nFROM\r\n temp.test_sets AS device_infos\r\nJOIN (\r\n SELECT\r\n google_ad_id\r\n FROM\r\n test*\r\n)";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}