// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(select)(.*?)(from)[\\r\\n]*").unwrap();
let string = "SELECT\\r\\n money\\r\\nFROM\\r\\n accounts
\"SELECT\\r\\n device_id\\r\\nFROM\\r\\n temp.test_sets AS device_infos\\r\\nJOIN (\\r\\n SELECT\\r\\n google_ad_id\\r\\n FROM\\r\\n test*\\r\\n)";
let substitution = "\\1 count(*) \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}