package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(select)(.*?)(from)[\\r\\n]*`)
var str = `SELECT\r\n money\r\nFROM\r\n accounts
"SELECT\r\n device_id\r\nFROM\r\n temp.test_sets AS device_infos\r\nJOIN (\r\n SELECT\r\n google_ad_id\r\n FROM\r\n test*\r\n)`
var substitution = "\1 count(*) \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}