# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(select)(.*?)(from)[\\r\\n]*"
test_str = ("SELECT\\r\\n money\\r\\nFROM\\r\\n accounts\n"
"\"SELECT\\r\\n device_id\\r\\nFROM\\r\\n temp.test_sets AS device_infos\\r\\nJOIN (\\r\\n SELECT\\r\\n google_ad_id\\r\\n FROM\\r\\n test*\\r\\n)")
subst = "\\1 count(*) \\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.