re = /(select)(.*?)(from)[\\r\\n]*/im
str = 'SELECT\\r\\n money\\r\\nFROM\\r\\n accounts
"SELECT\\r\\n device_id\\r\\nFROM\\r\\n temp.test_sets AS device_infos\\r\\nJOIN (\\r\\n SELECT\\r\\n google_ad_id\\r\\n FROM\\r\\n test*\\r\\n)'
subst = '\\1 count(*) \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result