$re = '/(select)(.*?)(from)[\\\\r\\\\n]*/im';
$str = 'SELECT\\r\\n money\\r\\nFROM\\r\\n accounts
"SELECT\\r\\n device_id\\r\\nFROM\\r\\n temp.test_sets AS device_infos\\r\\nJOIN (\\r\\n SELECT\\r\\n google_ad_id\\r\\n FROM\\r\\n test*\\r\\n)';
$subst = "\1 count(*) \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;