use strict;
my $str = 'SELECT\\r\\n money\\r\\nFROM\\r\\n accounts
"SELECT\\r\\n device_id\\r\\nFROM\\r\\n temp.test_sets AS device_infos\\r\\nJOIN (\\r\\n SELECT\\r\\n google_ad_id\\r\\n FROM\\r\\n test*\\r\\n)';
my $regex = qr/(select)(.*?)(from)[\\r\\n]*/imp;
my $subst = '\\1 count(*) \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";