# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^aaa_//gm;t' <<< "aaa_house
aaa_car
aaa_table
aaa_love
aaa_hate
aaa_life"