// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^aaa_").unwrap();
let string = "aaa_house
aaa_car
aaa_table
aaa_love
aaa_hate
aaa_life";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}