$re = '/^aaa_/m';
$str = 'aaa_house
aaa_car
aaa_table
aaa_love
aaa_hate
aaa_life';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;