re = /^aaa_/m
str = 'aaa_house
aaa_car
aaa_table
aaa_love
aaa_hate
aaa_life'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result