import re
regex = re.compile(r"^aaa_", flags=re.MULTILINE)
test_str = ("aaa_house\n"
"aaa_car\n"
"aaa_table\n"
"aaa_love\n"
"aaa_hate\n"
"aaa_life")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)