import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^aaa_";
final String string = "aaa_house\n"
+ "aaa_car\n"
+ "aaa_table\n"
+ "aaa_love\n"
+ "aaa_hate\n"
+ "aaa_life";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}