#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?x)\B\*\b([^*]*(?:\b\*\b[^*]*)*)\b\*\B"
Local $sString = "The well known *H*rry P*tter*."
Local $sSubst = "<em>\1</em>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)