const regex = new RegExp('\\B\\*\\b([^*]*(?:\\b\\*\\b[^*]*)*)\\b\\*\\B', 'g')
const str = `The well known *H*rry P*tter*.`;
const subst = `<em>\1</em>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);