import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B\\*\\b([^*]*(?:\\b\\*\\b[^*]*)*)\\b\\*\\B";
final String string = "The well known *H*rry P*tter*.";
final String subst = "<em>\\1</em>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}