re = /\B\*\b([^*]*(?:\b\*\b[^*]*)*)\b\*\B/x
str = 'The well known *H*rry P*tter*.'
subst = '<em>\\1</em>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result