import re
regex = re.compile(r"""
\B\*\b([^*]*(?:\b\*\b[^*]*)*)\b\*\B
""", flags=re.VERBOSE)
test_str = "The well known *H*rry P*tter*."
subst = "<em>\\1</em>"
result = regex.sub(subst, test_str)
if result:
print(result)