$re = '/\B\*\b([^*]*(?:\b\*\b[^*]*)*)\b\*\B/x';
$str = 'The well known *H*rry P*tter*.';
$subst = "<em>\1</em>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;