package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)\B\*\b([^*]*(?:\b\*\b[^*]*)*)\b\*\B`)
var str = `The well known *H*rry P*tter*.`
var substitution = "<em>\1</em>"
fmt.Println(re.ReplaceAllString(str, substitution))
}