using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B\*\b([^*]*(?:\b\*\b[^*]*)*)\b\*\B";
string substitution = @"<em>\1</em>";
string input = @"The well known *H*rry P*tter*.";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}