package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+),([^,]+),([^,]+),([^,]+),([^,]+)$`)
var str = `1900,Humbert Ier,Gottlieb Daimler,Friedrich Nietzsche,Oscar Wilde`
var substitution = "$1,$2,$1,$3,$1,$4,$1,$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}