use strict;
my $str = '1900,Humbert Ier,Gottlieb Daimler,Friedrich Nietzsche,Oscar Wilde';
my $regex = qr/^(\d+),([^,]+),([^,]+),([^,]+),([^,]+)$/mp;
my $subst = '$1,$2,$1,$3,$1,$4,$1,$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";