import re
regex = re.compile(r"^(\d+),([^,]+),([^,]+),([^,]+),([^,]+)$", flags=re.MULTILINE)
test_str = "1900,Humbert Ier,Gottlieb Daimler,Friedrich Nietzsche,Oscar Wilde"
subst = "$1,$2,$1,$3,$1,$4,$1,$5"
result = regex.sub(subst, test_str)
if result:
print(result)