re = /^(\d+),([^,]+),([^,]+),([^,]+),([^,]+)$/m
str = '1900,Humbert Ier,Gottlieb Daimler,Friedrich Nietzsche,Oscar Wilde'
subst = '$1,$2,$1,$3,$1,$4,$1,$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result