import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+),([^,]+),([^,]+),([^,]+),([^,]+)$";
final String string = "1900,Humbert Ier,Gottlieb Daimler,Friedrich Nietzsche,Oscar Wilde";
final String subst = "$1,$2,$1,$3,$1,$4,$1,$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}