# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(\s*\/.*?\/\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')/$1XXXX$1/g;t' <<< "Test
a=\"abc\";
b='def';
c=\"That's the way to do it\";
d='That\'s the way \"to do it\"';
e=e.replace(//g, '\"');
f=f.replace(/'/g, '\"');
g=g.replace(/\'/g, '\"');
h=h.replace(/\\"/g, '\\"');
i=i.replace(/\\\"/g, '\\\"');
"